15AH, San Francisco

California, United States.

Send Your Mail At:

tianyingkejishe@sina.cn

Working Hours

Mon-Sat: 9.30am To 7.00pm

作者标题

Autem vel eum iriure dolor in hendrerit in vulputate velit esse molestie consequat, vel illum dolore eu feugiat nulla facilisis at vero eros et dolore feugait.

Author Archive by stormwind

【光猫】北京移动最新吉比特H3-2S光猫获取超级管理密码,改桥接必备

1.使用光猫背后的普通用户名登录进光猫,浏览器复制以下链接打开

http://192.168.1.1/usr=CMCCAdmin&psw=aDm8H%25MdA&cmd=1&telnet.gch

2.通过telnet进入光猫

输入:telnet 192.168.1.1
用户名、密码如下:
CMCCAdmin
aDm8H%MdA

3.查看一下登陆信息,可以看到账号密码全部进行了加密

sidbg 1 DB p DevAuthInfo

以下内容为正常显示:

<Tbl name="DevAuthInfo" RowCount="2">
<Row No="0">
<DM name="ViewName" val="IGD.AU1"/>
<DM name="Enable" val="1"/>
<DM name="IsOnline" val="0"/>
<DM name="AppID" val="1"/>
<DM name="User" val="******"/>
<DM name="Pass" val="******"/>
<DM name="Level" val="1"/>
<DM name="Extra" val=""/>
<DM name="ExtraInt" val="0"/>
</Row>
<Row No="1">
<DM name="ViewName" val="IGD.AU2"/>
<DM name="Enable" val="1"/>
<DM name="IsOnline" val="0"/>
<DM name="AppID" val="1"/>
<DM name="User" val="******"/>
<DM name="Pass" val="******"/>
<DM name="Level" val="2"/>
<DM name="Extra" val=""/>
<DM name="ExtraInt" val="0"/>
</Row>
</Tbl> 

4.修改CMCCAdmin的登陆密码

sidbg 1 DB set DevAuthInfo 0 Pass admin

5.保存

sidbg 1 DB save 

6.使用账户正常登录光猫即可

CMCCAdmin
admin

7.指令集

#列出所有表

sidbg 1 DB p all

#查看 TELNET 信息

sidbg 1 DB p TelnetCfg

#查看 查看用户 信息

sidbg 1 DB p DevAuthInfo



修改管理员超级账号为 CMCCAdmin (可自定义)

sidbg 1 DB set DevAuthInfo 0 User CMCCAdmin



修改管理员超级账号的密码 aDm8H%MdA (可自定义)

sidbg 1 DB set DevAuthInfo 0 Pass aDm8H%MdA



修改配置 永久 开启 TELNET

#开启TELNET

sidbg 1 DB set TelnetCfg 0 TS_Enable 1

#开放TELNET LAN端口

sidbg 1 DB set TelnetCfg 0 Lan_Enable 1



#关闭TELNET

sidbg 1 DB set TelnetCfg 0 TS_Enable 0

#关闭TELNET LAN端口

sidbg 1 DB set TelnetCfg 0 Lan_Enable 0



#修改TELNET账号 改为 root (可自定义)

sidbg 1 DB set TelnetUser 0 Username root

#修改TELNET密码 改为 admin (可自定义)

sidbg 1 DB set TelnetUser 0 Password admin



#修改TELNET账号 改为 root (可自定义)

sidbg 1 DB set TelnetUser 1 Username root

#修改TELNET密码 改为 admin (可自定义)

sidbg 1 DB set TelnetUser 1 Password admin



#记得最好保存下配置

sidbg 1 DB save 

8.配置桥接模式

找到网络里面 Internet连接  把没用的连接拍照记录vlan id后都删除,重新建立一个vlan id=10的 bridge即可

注意一般2口是IPTV 不要选中

【PCIE】Linux pcie支持热插拔

1、驱动安装

2、查询pcie port码

root@ssss:~# lspci
0000:00:00.0 PCI bridge: Freescale Semiconductor Inc Device 8d90 (rev 20)
0000:01:00.0 Ethernet controller: Device 1ec4:555 (rev 01)
0001:00:00.0 PCI bridge: Freescale Semiconductor Inc Device 8d90 (rev 20)
0002:00:00.0 PCI bridge: Freescale Semiconductor Inc Device 8d90 (rev 20)

3、删除pcie设备

echo 1 > /sys/bus/pci/devices/0000\:03\:00.0/remove

4、重新加载pcie设备

echo 1 > /sys/bus/pci/rescan

【JavaScript】16位有符合整数处理

1、理解JavaScript对数据的默认逻辑

JS 中所有的数字类型,实际存储都是通过 8 字节 double 浮点型 表示的。浮点数并不是能够精确表示范围内的所有数的, 虽然 double 浮点型的范围看上去很大: 2.23x10^(-308) ~ 1.79x10^308。 可以表示的最大整数可以很大,但能够精确表示,使用算数运算的并没有这么大。

2、16位有符号整数处理

由于JavaScript默认是按照32位数据处理,那么对于16位有符合数据处理,符号位在第32位,这么理解就对了。1代表负数,0代表整数。

举例:
var value=0xff88
console.log(0xff88 | 0xffff0000)

【Git】git仓库中有子仓库,子仓库代码上传不成功

如题git仓库中有子仓库,子仓库代码上传不成功,首先我们应该避免仓库嵌套的问题,这种一般不是合理的.应该使用package来管理,不管是私有还是共有.

如果想快速解决问题.可以使用下面的方法:

# 进到子仓库.git所在的目录执行下面命令
rm -rf .git
git rm -r --cached .

【Dockers】启动问题排查

1、尝试启动docker

root@DESKTOP-3TQ8K9B:~# systemctl start docker
Job for docker.service failed because the control process exited with error code.
See "systemctl status docker.service" and "journalctl -xeu docker.service" for details.

2、查看启动log

root@DESKTOP-3TQ8K9B:~# sudo dockerd --debug
INFO[2022-08-05T23:05:51.543106408+08:00] Starting up
......
failed to start daemon: Error initializing network controller: error obtaining controller instance: unable to add return rule in DOCKER-ISOLATION-STAGE-1 chain:  (iptables failed: iptables --wait -A DOCKER-ISOLATION-STAGE-1 -j RETURN: iptables v1.8.7 (nf_tables):  RULE_APPEND failed (No such file or directory): rule in chain DOCKER-ISOLATION-STAGE-1
 (exit status 4))

3、解决问题

sudo update-alternatives --set iptables /usr/sbin/iptables-legacy

【Armbian】优盘挂在管理WEB

1、安装依赖库

apt-get install ntfs-3g

2、查看所有插入优盘

lsblk

3、格式化优盘(根据以上查到的结果)

mkfs.ext4 /dev/sda

4、安装可视化管理WEB

apt update && apt install cockpit cockpit-storaged -y

访问管理页面

http://路由器IP地址:9090
如
http://192.168.1.100:9090

登录管理,账户为armbian本身登录账户密码

5、打开/etc/fstab文件,修改参数。

/dev/sda1      /mnts     ext4    defaults,nofail   0    2

/dev/sda1 u盘位置
/mnts 挂载位置(甜糖要挂载在这里)
ext4 u盘格式 vfat ntfs ext4…
defaults,nofail 自动挂载并忽略失败
0 2 顺序之类的